Skip to content

regisu blog

Blog z notatkami …

Parę linków bardzo przydatnych przy rozwiązywaniu problemów z BGP.

Polskie:

HAWE
THINX (dawniej ACX) – należy wybrać node THINX
TPIX
(AS 29535)
TPSA (AS 5617)
EPIX
PLIX
NETIA
TKT

Zagraniczne:

LEVEL3
TINET (inaczej TISCALI a obecnie INTELIQUENT)
TELIA
ATRATO

How to change MAC address

Ku pamięci, bo może się przydać.

I jeszcze polecany przez rozie’go macchanger, który ma naprawdę duże możliwości w porównaniu z rozwiązaniem zaproponowanym przeze mnie.

W Cisco 6500 tylko Sup32 i Sup720 obsługują IPv6 w hardware.

Sup2

Sup2 obsługuje IPv6 osbługuje przez software, a nie przez hardware. Czyli przez procesor.
Wydajność takiego rozwiązania to około 200kpps, czyli 200 000 pakietów
na sekundę. Co w zależności od wielkości pakietu np. dla 64 bajtów daje
przepustowość 97Mbps, a dla 1500 bajtów około 2Gbps. Ale są to wartości
mocno teoretyczne, wynikające z prostego przeliczenia, które w
rzeczywistości są dużo niższe i powodują obciążenie procesora w routerze.

configure syslog add X.X.X.X vr „VR-Mgmt” local7

conf log target syslog X.X.X.X local7 severity notice

enable syslog

enable cli-config-logging

Ot prosty skrypt, wykorzystywany przeze mnie do restartowania antenek Ubiquiti, bo się lubią czasem dziwnie powiesić i gubić pakiety:)


#!/usr/bin/env ruby

require 'rubygems'
require 'net/ssh'


Net::SSH.start( "X.X.X.X" , "USER", :password => "PASSWORD", :port => 22) do |ssh|
puts ssh.exec! "reboot"
end

Floating static route polega na tym, że konfigurujemy trasę statyczną z większym AD<Administrative Distance> niż to jakie ma dynamiczny protokół routingu od którego również tą trasę otrzymujemy. Dzięki temu, gdy wyleci nam trasa dynamiczna to do tablicy routingu wrzucona zostaje trasa statyczna, która normalnie jest ignorowana ze względu na wysoki AD.

Wow dzisiaj zacząłem ostro eksperymentować z MMSami bo wkurzało mnie, że tak fajny telefon nie potrafi wysyłać i odbierać MMSów. W końcu załapał. Ustawienia jakich użyłem to:

Nazwa: mms

APN: mms.plusgsm.pl

Proxy: <nie ustawione>

Port: <nie ustawione>

Nazwa użytkownika: <nie ustawione>

Hasło: <nie ustawione>

Serwer: <nie ustawione>

MMSC: http://mms.plusgsm.pl:8002

Proxy dla wiadomości MMS: 212.2.96.16

Port MMS: 8080

Protokół MMS: WAP 2.0

MCC: 260

MNC: 01

Typ uwierzytelniania: Brak

Typ APN: mms
Kurde podziałało jeden dzień i przestało … ktoś może wie czemu?

APC oczywiście, zamiast trzymać się jakiegoś standardu <np. RS232>, wolało zrobić swój własny. Więc zwykłym kablem szeregowym nie się podłączymy do konsoli UPSa, null modemem też nie. Trzeba mieć specjalny ichni kabel, który można kupić albo zrobić samemu. Ten drugi sposób jest oczywiście tańszy i szybszy. Tutaj można znaleźć opis w jaki sposób trzeba polutować kabel, żeby działał z UPSami APC. Potrzeba do tego jednej wtyczki DB9 male <od strony UPSa> i jednej DB9 female<do kompa> i jakiegoś trzy żyłowego przewodu.

Dodatkowo należy pamiętać, o ustawieniach parametrów konsoli. Nie jest to standardowe 9600 8n1, jest to 2400 8n1 no flow control.

Reset hasła w karcie managementowej jest prosty. Wciskamy przycisk reset i trzymamy dopóki dioda status nie zacznie mrugać na przemian na zielono i pomarańczowo. Wtedy puszczamy przycisk i jeszcze raz szybko naciskamy. I już user i pass zresetowane są już do domyślnych ustawień.

Domyśly user: apc, pass: apc

  • Wciskamy klawisz brake zanim IOS zdąży się załadować
  • Trzeba zmienić wartość config-register na  0x042 poleceniem:  >o/r 0x042
  • potem init: >i
  • IOS inicjalizuje się z pominięciem wczytywania konfiguracji
  • jak już się zaloguje to przechodzimy do trybu enable i wpisujemy erase nvram: i ENTER
  • następnie jeszcze tylko zmieniamy config-register na wartość 0x2102 żeby znowu wczytywał konfigurację: config-reg 0x2102

QinQ na Dellach powerconnect 6200

Topologia

KOMP<-Fa0/3-> 3500<-Fa0/1|Fa0/1-> 3550<-Fa0/48|1/g24->6224<-1/g21|Fa0/1-> 2950<-Fa0/23->ROUTER

Konfiguracja

Konfiguracja 3500:

interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,3,5,1002-1005
switchport mode trunk
interface FastEthernet0/3
switchport access vlan 5

Konfiguracja 3550:

system mtu 1546
interface FastEthernet0/1
switchport access vlan 10
switchport mode dot1q-tunnel
no cdp enable
spanning-tree bpdufilter enable
interface FastEthernet0/48
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10
switchport mode trunk

Konfiguracja 6224:

Port qinq:

interface ethernet 1/g21
switchport access vlan 10
mtu 1546

Port trunkowy do drugiego switcha:

interface ethernet 1/g24
switchport mode trunk
switchport forbidden vlan add 1
switchport trunk allowed vlan add 10
mode dvlan-tunnel
mtu 1546

Konfiguracja 2950:

interface FastEthernet0/23
switchport access vlan 5