Skip to content

regisu blog

Blog z notatkami …

Archive

Category: Dell

QinQ na Dellach powerconnect 6200

Topologia

KOMP<-Fa0/3-> 3500<-Fa0/1|Fa0/1-> 3550<-Fa0/48|1/g24->6224<-1/g21|Fa0/1-> 2950<-Fa0/23->ROUTER

Konfiguracja

Konfiguracja 3500:

interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,3,5,1002-1005
switchport mode trunk
interface FastEthernet0/3
switchport access vlan 5

Konfiguracja 3550:

system mtu 1546
interface FastEthernet0/1
switchport access vlan 10
switchport mode dot1q-tunnel
no cdp enable
spanning-tree bpdufilter enable
interface FastEthernet0/48
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10
switchport mode trunk

Konfiguracja 6224:

Port qinq:

interface ethernet 1/g21
switchport access vlan 10
mtu 1546

Port trunkowy do drugiego switcha:

interface ethernet 1/g24
switchport mode trunk
switchport forbidden vlan add 1
switchport trunk allowed vlan add 10
mode dvlan-tunnel
mtu 1546

Konfiguracja 2950:

interface FastEthernet0/23
switchport access vlan 5

Oprócz sprzętu Cisco miałem okazję zarządzać też paroma switchami Della z serii 6000. Niestety producent nie pomyślał w nich totalnie o tym, że nawet<a może zwłaszcza!> sprzęt sieciowy wymaga backupu. Niby jest opcja w CLI przełącznika by zapisać obecny konfig jako backup, ale … na przełączniku. A to nijak nie pomoże w przypadku padu urządzenia, czy innej katastrofy, która spowoduje, że nie będzie można odczytać z niego tej konfiguracji.

Dlatego tez postanowiłem sam napisać sobie skrypt, który mi ten backup zrobi. Wykorzystałem do tego: pythona z biblioteką telnetlib i serwer tftp. Pewną rolę odegrał tu także plik /etc/hosts. 🙂

kontynuuj czytanie …

No tak dzisiaj musiałem zrobić małe sniffowanie ruchu na porcie do klienta, bo nie wiadomo skąd leci do niego 400Mbit którego nie powinno tam być.

No i natknąłem się na problemik jak zrobić port mirror na switch’u Dell’a. Na szczęście okazało się to banalne. Trzeba to zrobić tak:

  • Wchodzimy w tryb configure
  • Teraz trzeba podać port źródłowy, który chcemy mirror’ować oraz kierunek interesującego nas ruchu monitor session 1 source interface 1/g1 [tx, rx, both]
  • W razie potrzeby można dodać jeszcze kilka portów źródłowych
  • Następnie trzeba podać port docelowy, na który ten ruch ma być kopiowany monitor session 1 destination interface 1/g2
  • I na koniec trzeba daną sesję włączyć monitor session 1 mode

I to w zasadzie tyle.