Skip to content

regisu blog

Blog z notatkami …

Archive

Category: Sieci

Parę linków bardzo przydatnych przy rozwiązywaniu problemów z BGP.

Polskie:

HAWE
THINX (dawniej ACX) – należy wybrać node THINX
TPIX
(AS 29535)
TPSA (AS 5617)
EPIX
PLIX
NETIA
TKT

Zagraniczne:

LEVEL3
TINET (inaczej TISCALI a obecnie INTELIQUENT)
TELIA
ATRATO

W Cisco 6500 tylko Sup32 i Sup720 obsługują IPv6 w hardware.

Sup2

Sup2 obsługuje IPv6 osbługuje przez software, a nie przez hardware. Czyli przez procesor.
Wydajność takiego rozwiązania to około 200kpps, czyli 200 000 pakietów
na sekundę. Co w zależności od wielkości pakietu np. dla 64 bajtów daje
przepustowość 97Mbps, a dla 1500 bajtów około 2Gbps. Ale są to wartości
mocno teoretyczne, wynikające z prostego przeliczenia, które w
rzeczywistości są dużo niższe i powodują obciążenie procesora w routerze.

configure syslog add X.X.X.X vr „VR-Mgmt” local7

conf log target syslog X.X.X.X local7 severity notice

enable syslog

enable cli-config-logging

Floating static route polega na tym, że konfigurujemy trasę statyczną z większym AD<Administrative Distance> niż to jakie ma dynamiczny protokół routingu od którego również tą trasę otrzymujemy. Dzięki temu, gdy wyleci nam trasa dynamiczna to do tablicy routingu wrzucona zostaje trasa statyczna, która normalnie jest ignorowana ze względu na wysoki AD.

  • Wciskamy klawisz brake zanim IOS zdąży się załadować
  • Trzeba zmienić wartość config-register na  0x042 poleceniem:  >o/r 0x042
  • potem init: >i
  • IOS inicjalizuje się z pominięciem wczytywania konfiguracji
  • jak już się zaloguje to przechodzimy do trybu enable i wpisujemy erase nvram: i ENTER
  • następnie jeszcze tylko zmieniamy config-register na wartość 0x2102 żeby znowu wczytywał konfigurację: config-reg 0x2102

QinQ na Dellach powerconnect 6200

Topologia

KOMP<-Fa0/3-> 3500<-Fa0/1|Fa0/1-> 3550<-Fa0/48|1/g24->6224<-1/g21|Fa0/1-> 2950<-Fa0/23->ROUTER

Konfiguracja

Konfiguracja 3500:

interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,3,5,1002-1005
switchport mode trunk
interface FastEthernet0/3
switchport access vlan 5

Konfiguracja 3550:

system mtu 1546
interface FastEthernet0/1
switchport access vlan 10
switchport mode dot1q-tunnel
no cdp enable
spanning-tree bpdufilter enable
interface FastEthernet0/48
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10
switchport mode trunk

Konfiguracja 6224:

Port qinq:

interface ethernet 1/g21
switchport access vlan 10
mtu 1546

Port trunkowy do drugiego switcha:

interface ethernet 1/g24
switchport mode trunk
switchport forbidden vlan add 1
switchport trunk allowed vlan add 10
mode dvlan-tunnel
mtu 1546

Konfiguracja 2950:

interface FastEthernet0/23
switchport access vlan 5

Żeby zresetować hasło w switchu Extreme 48si trzeba:

  • Podłączyć się kablem konsolowym do switcha (standard 9600 8n1)
  • Odpalić konsolę w minicomie albo innym ulubiony emulatorze terminala.
  • Trzymając spację podłączyć switcha do prądu
  • Powinno pokazać się się BootMenu. Jeśli wciśniemy h to pokażą się dostępne komendy:
    • 1: Select primary code image
    • 2: Select secondary code image
    • 3: Select primary configuration
    • 4: Select secondary configuration
    • b: Change baud rate
    • d: Force default configuration
    • f: Boot on board flash
    • h: Help
    • k: Erase selected configuration
    • p: Boot PCMCIA card
    • s: Load code image from serial port using XMODEM
  • Wpisujemy 1 ( wybiera pierwszy obraz z systemem)
  • Wpisujemy k – czyści konfig danego obrazu
  • Wpisujemy d – wymusza domyślną konfigurację
  • Wpisujemy f – ładuje system
  • I to już koniec. Teraz można się zalogować z defaultowym loginem: admin i brakiem hasła

Mamy już swoją publiczną podsieć IP. Teraz przydałoby się skonfigurować dla niej revDNS’y.

  1. Na początek trzeba dodać do naszego obiektu inetnum dodatkowe pole mnt-domains, które informuje o tym, kto może stworzyć obiekt domain dla tej sieci. Wskazujemy tu nasz obiekt maintainer. Robimy update bazy RIPE i sprawdzamy czy wszystko jest ok.
  2. Teraz trzeba się wziąć za konfigurację serwera DNS. Dzielimy naszą klasę adresową na bloki o wielkości /24. Teraz dla każdego bloku trzeba na serwerze DNS stworzyć nową domenę revDNS w formacie x.x.x.in-addr.arpa.
    Rekord musi zawierać:
    – dwa wpisy NS po jednym dla każdego serwera DNS
    – rekord SOA
  3. Teraz trzeba dodać obiekty domain w RIPE dla każdego bloku /24
  4. Jeśli nie popełniliśmy błędu to wszystko powinno być ok.
  5. Weryfikujemy jeszcze czy nasz rekord został utworzony: whois x.x.x.in-addr.arpa

Resetowanie aironet 1200 do fabrycznych ustawień:

  1. Odłączamy accesspointa od prądu
  2. Wciskamy przycisk MODE na obudowie i podłączamy prąd
  3. Czekamy aż dioda Status zaświeci się na pomarańczowo i puszczamy przycisk MODE
  4. Podłączamy się kablem konsolowym do accesspointa. Po resecie hasło do enable to Cisco

Features:

Są dwa interfejsy radiowe w aironetach 1200:

  • interfejs dot11Radio 0  – 2,4GHz
  • interfejs dot11Radio 1 – 5GHz

A także:

  • fizyczny interfejs FastEthernet 0
  • wirutalny interfejs zarządzający BVI 1

Aironet 1200 obsługuje do 16 SSID. Każdy SSID to osobny VLAN.

Konfiguracja interfejsu zarządzania:

Niestety na aironet 1200 nie można użyć tagowanego VLANu do zarządzania accesspointem. Dlatego też na porcie w switchu do którego jest podłączony punkt dostępowy trzeba nasz VLAN zarządzający ustawić jako natywny(nietagowany). Można to zrobić wpisując na porcie przełącznika polecenia:

switch(config-if)#switchport trunk native vlan numerek_nativeVLANu
switch(config-if)#switchport trunk allowed vlan numerek_nativeVLANu

To nam załatwia sprawę switcha, został jeszcze accesspoint. Aironet ma do zarządzania przewidziany specjalny interfejs BVI1, na którym wystarczy skonfigurować adres IP oraz maskę podsieci. O tak:

ap(config)#int bvI 1
ap(config-if)#ip address x.x.x.x y.y.y.y
ap(config-if)#no shutdown

I już można pingać naszego accesspointa z sieci managementowej, a także(w zależności od tego co skonfigurowaliśmy) telnetować lub SSHować się na niego.

Konfiguracja mutliSSID:

Cisco aironet 1200 umożliwia skonfigurowanie do 16 SSID, każdy SSID to osobny VLAN, a co za tym idzie osobna podsieć.

Najpierw trzeba skonfigurować port na switchu do którego podłączony jest punkt dostępowy tak by przepuszczał nasze VLANy do accesspointa. Przypuśćmy, że jest to VLANy X.

switch(config-if)#switch mode trunk
switch(config-if)#switch trunk allowed vlan add X

I jeśli chodzi o switcha to wszystko(zakładam, że na przełączniku są już dodane VLANy, które chcemy przekazać do APka).

Musimy zając się jeszcze konfiguracją aironeta. Na początek podobnie jak się to robi w routerach, trzeba na porcie FastEthernet 0 dodać wirtualne interfejsy z naszymi VLANami i przypisać je do odpowiednich bridge-grup. Każdy VLAN to osobna bridge-grupa.

ap(config)#interface FastEthernet 0.X
ap(config-if)#encapsulation dot1Q X
ap(config-if)#bridge-group 2

Potem trzeba jeszcze utworzyć SSID i przypisać numer VLAN. Żeby uprościć przykład konfigurujemy uwierzytelnianie otwarte(czyli każdy ma dostęp).

ap(config)#dot11 ssid NazwaSSID
ap(config-ssid)#vlan X
ap(config-ssid)#guest-mode
ap(config-ssid)#authentication open

Ok mamy skonfigurowany interfejs fizyczny, mamy SSID to teraz jeszcze trzeba skonfigurować wirtualny interfejs radiowy z naszym VLANem i przypisać bridge-grupę.

ap(config)#interface Dot11Radio0.X
ap(config-if)#encapsulation dot1Q X
ap(config-if)#bridge-group 2

Ostatnia rzecz to przypisanie SSID do interfejsu Dot11Radio0

ap(config)#interface Dot11Radio0
ap(config-if)#ssid NazwaSSID

I teraz już jeśli wszystko dalej na switchu i routerze mamy skonfigurowane dobrze, to powinniśmy mieć dostęp do naszego VLANu.

Jakby ktoś miał coś ciekawego do dodania albo poprawienia to zachęcam do komentowania 🙂

Ku pamięci. Konfiguracja strefy czasowej oraz zmiany czasu z letniego na zimowy i odwrotnie dla Polski na urządzeniach Cisco:

configure terminal
clock timezone CET 1
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00

Przydatne także są dwa polecenia podane przez kolegę cbr’a. Dzięki nim w logach oraz komunikatach debug będzie widać datę i godzinę wystąpienia zdarzenia:

service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime